Lithosphere The Lithium Community

Respected Contributor
Respected Contributor

Advanced search not working?

I'm just wondering if others see the same thing I do.  

If I go to the community search page  (/t5/forums/searchpage) and click on ADVANCED it says: "Use quotes to search for an "exact phrase".   As far as I can tell it doesn't work.  Using quotes makes no difference in our forum search.   I'm just wondering if it's a UI issue or a basic functionality issue.  Can anyone verify?   Thanks.

 

--
Community manager in the Micro Focus Community. My computer always used to beat me at chess, but it is no match for me now I changed the competition to kick boxing.
Tags (1)
0 Kudos
4 Replies 4
Honored Contributor Honored Contributor
Honored Contributor

Re: Advanced search not working?

In my community, exact phrase searches only work when using the advanced search field but not when using quotation marks.  This is in 18.12 but the search feature hasn't been upgraded yet.

I feel like I've been told that this is expected though, but I can't track down the ticket/topic. Maybe someone from Lithium can confirm.

----------------------------------

Lili McDonald
Community Manager @ National Instruments


0 Kudos
Reply
Loading...
Respected Contributor
Respected Contributor

Re: Advanced search not working?

I can't even get it to work in the advanced search field with or without quotes so you're doing better than I am.

 

--
Community manager in the Micro Focus Community. My computer always used to beat me at chess, but it is no match for me now I changed the competition to kick boxing.
0 Kudos
Reply
Loading...
Valued Contributor
Valued Contributor

Re: Advanced search not working?

We currently have a quiet clean stage on 18.12, not so much content on it. My findings:

"exact phrase" gives search result with the exact phrase in it. If exact or phrase appear alone, they are highlighted as well. There is no search result without the "exact phase"

Searching exact phrase (same search without ") gives search results where only one of the words has been found.

To proove this, I searched for "non exisiting exact phrase" and the search result for the search term with " was empty and the search without " yielded results.

I haven't checked if there are settings to influence how exact search results should be.

 


0 Kudos
Reply
Loading...
Respected Contributor
Respected Contributor

Re: Advanced search not working?

I looked for a pairing of words in our community that was unusual, but the words individually were not.    I had one specific post in mind that had that adjacent pairing.   I then went to the advanced search page and did two searches, one with quotation marks and one without using that pairing of words.  In both cases the post I wanted to see was not on the first page of results, but the top results were posts that had both words, just not next to each other.   The quotation marks made no difference.    I tried this with multiple pairings and phrases with the same results.   

--
Community manager in the Micro Focus Community. My computer always used to beat me at chess, but it is no match for me now I changed the competition to kick boxing.
0 Kudos
Reply
Loading...